Back to overview
Resolved

Upstream carrier experiencing an outage

Aug 12, 2026 at 1:17pm UTC
Affected services
CANADA
NORTH AMERICA

Resolved
Aug 12, 2026 at 7:37pm UTC

We are pleased to confirm that all services have been fully restored by the upstream carrier as of approximately 11:40 AM ET. We are continuing to monitor the situation to ensure ongoing stability. Thank you for your patience.

Updated
Aug 12, 2026 at 4:02pm UTC

We are still awaiting updates from the upstream carrier. We will post another update shortly.

Created
Aug 12, 2026 at 1:17pm UTC

We are currently investigating reports of service disruptions caused by an upstream provider's network issues. Their team is actively working on a resolution, and we will provide further updates as soon as more information becomes available.

As a result of this, some calls may not complete or complete intermittently.