Service Outage Notice – Windsor Region
Resolved
Jun 3, 2026 at 1:00pm UTC
UPDATE: Per the ILEC this issue has been resolved.
UPDATE:
We have received an update from our local ILEC. According to our ILEC Escalation Support, the major outage has been attributed to a cable cut in conjunction with a faulty hardware ring.
Their network team is currently working on a network redesign, which involves moving all affected circuits to a new configuration as part of the restoration efforts.
At this time, the ETR remains unknown. However, this has been classified as a high priority issue, and the ILEC team is actively working to restore services as quickly as possible.
We will continue to provide updates as additional information becomes available.
A major outage has been reported in the Windsor region, affecting multiple carriers, including IXICA. However, thanks to IXICA's multi-layered network architecture and built-in redundancies, not all numbers in the area are impacted.
The local ILEC has confirmed the outage, and teams are actively working to resolve the issue as quickly as possible.
Affected services